Pesquisa resultou em 1888 ocorrências

 Voltar para a pesquisa avançada

Re: Formula [Excel]

 por osvaldomp ¦  20 Out 2020 às 10:17 ¦  Fórum: Outros Assuntos ¦  Tópico: Formula [Excel] ¦  Respostas: 5 ¦  Exibições: 66

Experimente a fórmula matricial abaixo. No seu exemplo irá retornar o valor 2. =SOMA(--(FREQÜÊNCIA(SE(C2:C15684=F3;CORRESP(D2:D15684;D2:D15684;0));LIN(C2:C15684)-LIN(C2)+1)>0)) obs. por tratar-se de fórmula matricial, após colar uma cópia da fórmula em uma célula vazia aperte F2 e em seguida aperte ...

Re: Validação de dados sobrescrita com copiar e colar

 por osvaldomp ¦  20 Out 2020 às 08:49 ¦  Fórum: Macros e VBA ¦  Tópico: Validação de dados sobrescrita com copiar e colar ¦  Respostas: 1 ¦  Exibições: 21

Segue uma ideia. O código abaixo, instalado no módulo da planilha, irá limpar a Área de Transferência se for selecionada alguma célula das colunas A:D e assim irá impedir a operação de Colar naquelas colunas. Para acessar o módulo clique com o direito na guia da planilha de interesse e escolha Exibi...

Re: Alterar status de Caixa de Seleção

 por osvaldomp ¦  17 Out 2020 às 10:13 ¦  Fórum: Macros e VBA ¦  Tópico: Alterar status de Caixa de Seleção ¦  Respostas: 1 ¦  Exibições: 334

Experimente:

Código: Selecionar todos
Sub LimpaCaixasSeleção()
 Dim box As CheckBox
  Application.ScreenUpdating = False
  For Each box In Sheets("Planilha1").CheckBoxes
   box.Value = 0
  Next
End Sub

Re: Função para manter valor máximo alcançado na célula

 por osvaldomp ¦  15 Out 2020 às 21:42 ¦  Fórum: Fórmulas e Funções ¦  Tópico: Função para manter valor máximo alcançado na célula ¦  Respostas: 13 ¦  Exibições: 67

Beleza, o código está correto. Se o resultado está conforme o desejado, então parabéns! :D

Re: Função para manter valor máximo alcançado na célula

 por osvaldomp ¦  15 Out 2020 às 20:39 ¦  Fórum: Fórmulas e Funções ¦  Tópico: Função para manter valor máximo alcançado na célula ¦  Respostas: 13 ¦  Exibições: 67

Fabio, o erro no código ocorre porque as suas fórmulas na coluna E estão retornando erro #REF . para contornar substitua a fórmula ~~~> =PROCV(D4;Cotação!$1:$50;4;FALSO) por esta ~~~> =SEERRO(PROCV(D4;Cotação!$1:$50;4;FALSO);0) Também, se você quiser testar um código simplificado em substituição ao ...

Re: Somases que busque texto e mês específico

 por osvaldomp ¦  15 Out 2020 às 18:18 ¦  Fórum: Fórmulas e Funções ¦  Tópico: Somases que busque texto e mês específico ¦  Respostas: 2 ¦  Exibições: 42

Código: Selecionar todos
=SOMARPRODUTO((MÊS(C3:C100)=1)*(C3:C100<>"")*(B3:B100="TESTE");D3:D100)
Alternativa: coloque o mês em F2 e o texto em G2 e utilize a fórmula abaixo.
F2 = 1 e G2 = TESTE
Código: Selecionar todos
=SOMARPRODUTO((MÊS(C3:C100)=F2)*(C3:C100<>"")*(B3:B100=G2);D3:D100)

Re: Função para manter valor máximo alcançado na célula

 por osvaldomp ¦  15 Out 2020 às 18:04 ¦  Fórum: Fórmulas e Funções ¦  Tópico: Função para manter valor máximo alcançado na célula ¦  Respostas: 13 ¦  Exibições: 67

... alguma coisa a ser corrigido? Somente com base nas informações que você passou fica difícil avaliar a razão do erro. Disponibilize uma amostra do arquivo na forma em que ocorre o erro. Esqueci de mencionar no exemplo que são varias linhas , tenho que repetir o código ou tem como estende-la a va...

Re: Problema sem função definida

 por osvaldomp ¦  15 Out 2020 às 14:29 ¦  Fórum: Fórmulas e Funções ¦  Tópico: Problema sem função definida ¦  Respostas: 2 ¦  Exibições: 20

Experimente:

Código: Selecionar todos
=PROC(C10;{0;180000,01;360000,01;722000,01;1800000,01;3600000,01};{"1ª";"2ª";"3ª";"4ª";"5ª";"6ª"})
Se você alterar o arranjo da sua tabela então poderá utilizar outras funções como PROCV(), por exemplo. Pesquise.

Re: Macro não roda quando oculta uma planilha

 por osvaldomp ¦  15 Out 2020 às 08:37 ¦  Fórum: Macros e VBA ¦  Tópico: Macro não roda quando oculta uma planilha ¦  Respostas: 2 ¦  Exibições: 37

Alternativa:

Código: Selecionar todos
Private Sub CommandButton1_Click()
 Application.ScreenUpdating = False
 Sheets("Planilha1").Range("A2:N2").Copy
 Sheets("Relatorio").Cells(Rows.Count, 1).End(3)(2).PasteSpecial xlValues
End Sub

Re: Função para manter valor máximo alcançado na célula

 por osvaldomp ¦  15 Out 2020 às 08:07 ¦  Fórum: Fórmulas e Funções ¦  Tópico: Função para manter valor máximo alcançado na célula ¦  Respostas: 13 ¦  Exibições: 67

Olá, Fabio.

É provável que a inserção do link em D5 não esteja disparando o evento WS_Calculate.
Então, para forçar o disparo coloque em uma célula vazia =D5, assim o código será disparado a cada novo valor recebido do link.

Re: Função para manter valor máximo alcançado na célula

 por osvaldomp ¦  14 Out 2020 às 20:49 ¦  Fórum: Fórmulas e Funções ¦  Tópico: Função para manter valor máximo alcançado na célula ¦  Respostas: 13 ¦  Exibições: 67

Sim, senhor. É exatamente assim que os códigos funcionam.

Re: Controle de entradas

 por osvaldomp ¦  14 Out 2020 às 19:55 ¦  Fórum: Fórmulas e Funções ¦  Tópico: Controle de entradas ¦  Respostas: 2 ¦  Exibições: 48

Nas colunas ENTRADA e SAÍDA coloque data e hora, e calcule o total da permanência com ~~~> =SAÍDA - ENTRADA.

Exemplo:
ENTRADA ~~~> J4 = 13/10/20 7:00
SAÍDA ~~~> K4 = 14/10/20 18:00
permanência ~~~> = K4 - J4 ~~~> formate como Personalizado | [h]:mm

Re: Função para manter valor máximo alcançado na célula

 por osvaldomp ¦  14 Out 2020 às 17:18 ¦  Fórum: Fórmulas e Funções ¦  Tópico: Função para manter valor máximo alcançado na célula ¦  Respostas: 13 ¦  Exibições: 67

Em D5 o valor e variável, ... Por acaso ainda é aquele assunto em que o valor de D5 é inserido via link DDE ? Experimente os códigos abaixo. Só é possível um código por vez. O primeiro código utiliza a própria célula E5 para manter o maior valor atingido por D5 * 0,95 e o segundo utiliza a célula G...

Re: Configurar o relógio AM / PM após 24HS.

 por osvaldomp ¦  14 Out 2020 às 10:54 ¦  Fórum: Macros e VBA ¦  Tópico: Configurar o relógio AM / PM. Nos outros arquivo usar 24HS. ¦  Respostas: 2 ¦  Exibições: 35

Olá, Geneci. Não estou certo se entendi corretamente o que você deseja. " ... necessito configurar o relógio da Célula A1, quando abrir a planilha definir o relógio do sistema am/pm, quando fechar o arquivo redefinir para 24hs." A forma de exibição da hora na célula possui formatação própria e indep...

Re: resultado diferente com mesmo valor procurado( PROC?)

 por osvaldomp ¦  14 Out 2020 às 09:35 ¦  Fórum: Fórmulas e Funções ¦  Tópico: resultado diferente com mesmo valor procurado( PROC?) ¦  Respostas: 3 ¦  Exibições: 48

justin escreveu:segui a sua instruções e a celula fica vazia
1. insira o critério em D3, exemplo CLASSE01
2. cole em qualquer célula vazia uma cópia da fórmula sugerida pelo Estevão
3. aperte F2 e em seguida aperte juntas Ctrl+Shift+Enter
4. arraste a fórmula para baixo

Re: Necessito de ajuda

 por osvaldomp ¦  14 Out 2020 às 09:16 ¦  Fórum: Outros Assuntos ¦  Tópico: Buscar valores entre ABAS ¦  Respostas: 2 ¦  Exibições: 25

Experimente:

Código: Selecionar todos
=ÍNDICE('Res Compras'!A9:A20;CORRESP(C8;'Res Compras'!M9:M20;0))
Formate a célula para Personalizado | mmm/aa

Re: Função se

 por osvaldomp ¦  12 Out 2020 às 13:55 ¦  Fórum: Fórmulas e Funções ¦  Tópico: Função se ¦  Respostas: 3 ¦  Exibições: 35

Código: Selecionar todos
="S"&EXT.TEXTO(A1;3;1)
ou
Código: Selecionar todos
=SE(OU(EXT.TEXTO(A1;3;1)={"2";"3"});"S"&EXT.TEXTO(A1;3;1);"")

Re: FUNÇÃO SES

 por osvaldomp ¦  11 Out 2020 às 14:34 ¦  Fórum: Fórmulas e Funções ¦  Tópico: FUNÇÃO SES ¦  Respostas: 3 ¦  Exibições: 31

Experimente:

Código: Selecionar todos
=PROCV(C3;A2:B5;2;0)

Re: Problema com Função SE

 por osvaldomp ¦  09 Out 2020 às 19:31 ¦  Fórum: Fórmulas e Funções ¦  Tópico: Problema com Função SE ¦  Respostas: 1 ¦  Exibições: 23

Verifique se em E2 existe algum espaço antes ou depois da palavra "Sim". Verifique também se J2 e L2 são realmente valores numéricos. Se sim, as fórmulas abaixo colocadas em células vazias devem retornar VERDADEIRO. =ÉNÚM(J2) =ÉNÚM(L2) Se retornarem VERDADEIRO e E2 form "Sim" e ainda a sua fórmula c...

Re: NUMERO DE SERIE (SOMA + 1 NO VBA)

 por osvaldomp ¦  08 Out 2020 às 22:20 ¦  Fórum: Macros e VBA ¦  Tópico: NUMERO DE SERIE (SOMA + 1 NO VBA) ¦  Respostas: 6 ¦  Exibições: 47

livip escreveu: Nesse código eu obtive o erro "Type mismatch"
D4 deve conter somente 001196/2020

Se ainda assim der erro, então disponibilize o arquivo Excel, imagem não serve.

  • 1
  • 2
  • 3
  • 4
  • 5
  • 95
Web Scraping VBA + Excel

Usando a mesma lógica do script acima, tent[…]

Genial muito obrigado!

olá pessoal gostaria de uma ajuda para que […]

VLOOKUP Com váriaveis

Te amo cara kkkkk....Valeu!

Proxima Data com base em dias

Para facilitar a elaboração e teste […]

Boa tarde, Eu tenho a seguinte planilha: http://[…]

Acabei de enviar Assunto: Arquivo Corrompido

Boas, consegue anexar o ficheiro para o poder ajud[…]