Assuntos que não estiverem relacionados as categorias acima. Se não souber em qual categoria sua mensagem se encaixa, envie aqui.
Por luis30
#39355
Malta preciso de uma formula mas não estou a conseguir saber qual para o exemplo que vou dar a seguir.

Consumos de água/mês
Luis - 8 m3
Pedro - 4 m3
Andre - 15 m3

O preço da água é calculado através destes escalões em seguida:
Entre 0 e 5 m3 = 0,58€
Entre 6 e 10 m3 = 0,64€
Entre 11 e 15 m3 = 1,05€

Então eu quero saber quanto cada um deles vai pagar de consumo de água conforme os escalões acima.
E o cálculo é feito da seguinte forma:
Luis consumiu 8 m3;
(5*0,58) + (3*0,64) = 4,82€

Pedro 4 m3;
4*0,58= 2,32 €;

Andre 15 m3;
(5*0,58) + (5*0,64) + (5*1,05) = 11,35 €

Eu agora queria uma formula para me calcular isto desta forma. Alguem me consegue ajudar?!
Por osvaldomp
#39356
Considerando: A1=8, A2=4 e A3=15, cole a fórmula abaixo em B1 e arraste para baixo.
Código: Selecionar todos
=SOMARPRODUTO(--(A1>{0;5;10}); (A1-{0;5;10}); {0,58;0,06;0,41})
Por PedroFerreira
#61524
@osvaldomp, @osvaldomp, @osvaldomp, Boa tarde,
Vi a resposta que serve para o que preciso "=SOMARPRODUTO(--(A1>{0;5;10}); (A1-{0;5;10}); {0,58;0,06;0,41})". Mas como faço para alterar o valor dos escalões?! "{0,58;0,06;0,41}"
Obrigado
Por osvaldomp
#61525
Faça como na primeira postagem acima, forneça uma tabela com o valor por faixa ou por intervalo, forneça alguns exemplos e também o resultado esperado para cada exemplo. É recomendável para facilitar a obtenção de ajuda que você disponibilize essas informações em um arquivo de exemplo em Excel.

Ficar com o especto do que manualmente fiz na […]

Boa Noite estou tentando criar um gráfico d[…]

MACRO COM PLANILHA BLOQUEADA

Ola, uma sugestão é colocar essas d[…]

Boa noite!! Alguém sabe como bloquear uma […]

Boa noite!! Alguém sabe ocultar as f&oacut[…]

Olá, Geneci. Na planilha você coloco[…]

@MaxViana ! Olá, tentei fazer utilizan[…]

Boa tarde Francisco. @fcarlosc2018 , Ficou muito[…]