Dúvidas sobre cálculos, funções simples e aninhadas, fórmulas matriciais, etc.
  • Avatar do usuário
#60825
Olá Pessoal,

Eu gostaria de uma formula para contar o número de duplicidades dentro de uma base, desconsiderando zeros. Eu já tenho uma formula que identifica o numero de duplicidades, porém ela também está considerando valores com zero. Conseguem uma solução? Segue minha planilha com um exemplo. No caso, o resultado tem que ser 1, pois desconsiderando os zeros, existe apenas uma duplicidade no intervalo.
Você não está autorizado a ver ou baixar esse anexo.
Avatar do usuário
Por Deciog
#60827
Leonardo1234, Boa Tarde

Para a versão Excel antes de 2019, feche com CTRL + SHIFT + ENTER, são formula matricial

=SOMA(SE(FREQÜÊNCIA(SE(1-(NÃO(A2:A20>0));CORRESP(A2:A20;A2:A20;0));LIN(A2:A20)-LIN(A2)+1)>1;1))

Confere se é desta forma que desejas

Se minha resposta foi útil, clique em obrigado é uma forma de agradecimento da ajuda

Decio
#60828
Fala Deciog, está funcionando, porém eu notei que voce utiliza a linha A2 como referencia na formula. Pq assim, o que na verdade eu vou fazer com essa formula é inseeri-la em uma validação de dados para impedir que se insiram valores duplicados no intervalo. Se eu trancar a célula a2 vai continuar funcionando? Eu reparei que arrastando a formula para baixo, tendo a base trancada, porém com a a2 solta, a formula não funcionou. Você consegue me confirmar isso?
#60829
Vou mandar um anexo aonde a formula deixa de funcionar com base trancada e a célula solta. O ideal seria não utilizar qualquer célula da base como uma referencia, como acontece na minha formula original, aonde eu trabalho apenas com o intervalo.
Você não está autorizado a ver ou baixar esse anexo.
Avatar do usuário
Por Deciog
#60839
Leonardo1234, Bom Dia.

Primeiro notei que não agradeceu a ajuda dada

A formula esta contanto os duplicados em todo o intervalo, não é para arrastar para baixo

Agora voce colocou que quer na validação, então usa desta forma na validação personalizada

=CONT.SE($A$2:$A$20;A2)<=1

Confere se é desta forma que desejas

Se minha resposta foi útil, clique em obrigado é uma forma de agradecimento da ajuda

Decio

Boa noite. Sou novo no VBA, veja se resolve o seu […]

Top, asism ficou bem melhor, Muito Obrigado

Erro em tempo de Execução...

Bom dia amigos, neste código abaixo esta da[…]

Boa tarde. Segue uma opção. At&ea[…]

Leitura de planilha fechada

Consegui explicar :) :shock: :?: :?: N&at[…]

Bom-dia! Numa pasta do servidor [ D:\Server\BemVi[…]

Enviando email outlook

Boa tarde! Estou usando o codigo abaixo e esta fun[…]

Soma de valores por escalões.

Faça como na primeira postagem acima, forne[…]