Dúvidas sobre cálculos, funções simples e aninhadas, fórmulas matriciais, etc.
  • Avatar do usuário
#68041
Boa noite,

Agradeço a atenção,

Estou com a seguinte dúvida, como posso fazer uma fórmula que pegue a célula de referência e posicione na tabela aquela coluna específica. Já tentei o corresp, índice e procv não está dando certo, mesmo juntando as fórmulas.

Se na tabela tenho 5 colunas (A,B,C,D e E), se eu digito em uma célula a letra B, quero que os cálculos sejam com base nessa coluna. Podem me ajudar?
#68043
Seguem formas genéricas, veja se ajuda.

em A1 coloque a letra B
aí se você quiser fazer referência ao conteúdo de B10 ~~~> =INDIRETO(A1&10)

se quiser fazer referência ao intervalo B2:B20 ~~~> =DESLOC(INDIRETO(A1&2);;;19)
#68100
tentei usar INDIRETO para copiar a formula e pegar o número de referencia das celulas do cabeçalho, alguma luz pra ajudar nisso?
olha a imagem quero puxar a formula pra esquerda e copiar os valore $R2:$AP2 incrementando o valor ou puxando o número de linha de AC2,AD2, AE2...(linha rosa)
Imagem
#68103
Sugestão: disponibilize uma amostra do seu arquivo Excel com alguns dados (imagens não servem), com o resultado esperado colocado manualmente (sem fórmulas) e explique como chegou aos resultados.
#68109
@marcioissamu .

Veja no final da minha postagem a dica para anexar arquivos no fórum.
#68309
vou tentar continuar por aqui, se for o caso podemos abrir um novo tópico pra esse arquivo, tenho essa planilha e quero colocar na aba JOGOS, 15.000 possíveis jogos e na aba RESULTADOS chegar os acertos com o histórico dos resultados da lotofacil. Não consegui criar uma fórmula na aba resultados pra copiar para a direita e para baixo a sem ter que editar depois.
Você não está autorizado a ver ou baixar esse anexo.
#68311
Se entendi corretamente você quer contar as dezenas acertadas de cada um dos 15.000 jogos em cada um dos 1.727 resultados. É isso?
Se sim, segue um exemplo, se não, então explique.
A fórmula abaixo irá contar as dezenas acertadas de um jogo em cada um dos sorteios.

1. coloque os resultados dos sorteios em A:O a partir da linha 1
2. coloque as 15 dezenas do jogo em Q1:AD1

Cole uma cópia da fórmula em qualquer célula vazia e arraste para baixo até a última linha com resultados.
Código: Selecionar todos
=SOMARPRODUTO(CONT.SE(A1:O1;Q$1:AE$1))
#
#
marcioissamu escreveu: ... quero colocar na aba JOGOS, 15.000 possíveis jogos e na aba RESULTADOS chegar os acertos com o histórico dos resultados da lotofacil.
Considerando 15.000 jogos e considerando os 1.727 resultados dos sorteios que estão na sua planilha, a quantidade necessária de fórmulas será ~~~> 15.000 X 1.737 = 26+ milhões de fórmulas ... :shock:
#68329
marcioissamu escreveu: 17 Dez 2021 às 09:23 ... vamos ver se o PC aguenta.
Mantenha um extintor de incêndio por perto. ;) :D

Por exemplo, na linha 2 da planilha anexada, na […]

BUSCAR DADOS EM OUTRA ABA

preciso buscar informação de nome e […]

Como seria no excel, por exemplo, este calculo?

Deu Certo Amigo. Obrigado

Boa tarde! Patropi. Por tratar-se de uma conta co[…]

Ajuda na Formula

Através da imagem não dá para[…]

pode anexar seu pbix?

Today I will introduce the member of the Eleaf Ba[…]