Dúvidas sobre cálculos, funções simples e aninhadas, fórmulas matriciais, etc.
  • Avatar do usuário
  • Avatar do usuário
  • Avatar do usuário
Avatar do usuário
Por Estevaoba
#60862
Boa noite.

Não entendi o que você entende por "ocorrência contínua".
Para facilitar a criação e teste de fórmulas, favor postar um modelo da sua planilha, (não foto) explicando os critérios usados para chegar aos resultados esperados.
Clique em +Resposta, Adicionar um anexo, adicionar arquivos.

Ab.
Avatar do usuário
Por Angra
#60867
Bom dia
Por um problema interno(rede) no pc, n pude disponibilizar a plan exemplo, como faço regularmente. Infelizmente vou ter de postar outra foto. Espero q ajude
Imagem
Avatar do usuário
Por Angra
#60896
Boa noite
Planilha exemplo anexada
1.xlsx
Você não está autorizado a ver ou baixar esse anexo.
Avatar do usuário
Por Estevaoba
#60906
Código: Selecionar todos
=SE(MAIOR(FREQUÊNCIA(SE($G$9:$CC$9=33;COL($G$9:$CC$9));SE($G$9:$CC$9<>33;COL( $G$9:$CC$9)));LIN(A1))>1;MAIOR(FREQUÊNCIA(SE($G$9:$CC$9=33;COL($G$9:$CC$9));SE($G$9:$CC$9<>33;COL( $G$9:$CC$9)));LIN(A1));"")
Fórmula matricial. Se o seu Excel for anterior a 2019, confirme com Ctrl+Shift+Enter em vez de apenas Enter.
Copie para baixo.

Good luck!
Angra agradeceu por isso
Avatar do usuário
Por Angra
#60910
Bom dia
estevaoba, a matricial apesar de excelente, "pega" a maior sequencia contínua no intervalo, no entanto o resultado que preciso obter, é a primeira sequencia contínua a partir da primeira célula do intervalo ou seja G9. No exemplo da plan G9:I9 e assim sucessivamente
Grato
Avatar do usuário
Por Angra
#60911
Só complementando: na matricial desenvolvida, o 33 aparece como fixo e não é. São diferentes valores assumidos na formula
grato
Avatar do usuário
Por Estevaoba
#60933
A fórmula anterior lista todas as repetições. Eu pensei ser isso o que você queria.
Para exibir só a primeira, tente esta fórmula, também matricial.
Substitua F17 pela célula em que estiver o valor a ser consultado (33 no seu exemplo).
Código: Selecionar todos
=ÍNDICE(FREQÜÊNCIA(SE($G$9:$CC$9=F17;COL($G$9:$CC$9));SE(1-($G$9:$CC$9=F17);COL($G$9:$CC$9)));CORRESP(VERDADEIRO;FREQÜÊNCIA(SE($G$9:$CC$9=F17;COL($G$9:$CC$9));SE(1-($G$9:$CC$9=F17);COL($G$9:$CC$9)))>1;0))
Ab.
Angra agradeceu por isso
Avatar do usuário
Por Angra
#60943
Boa tarde
Uma pergunta mas sem querer abusar da sua gentileza: no tópico original (foto) tem dois valores, o 33 e 41. A matricial faz o q se pede com louvou, com os valores listados coluna após coluna. Mas se eu quiser q a matrix "pegue" só o 33 ignorando o 41, a matrix n pega. Seria possível, a matrix pegar G9, I9, K9... ou seja coluna sim, coluna não
Ficaria muito complexo essa alteração?
Se ficar, desconsidera o pedido e fica aqui minha gratidão :D :D
Avatar do usuário
Por Estevaoba
#60953
De nada. É um prazer ajudar.
Pra contar 8 eventos de "41" como no seu primeiro exemplo, você está usando dois critérios, pois os dois primeiros são alternados e os seis seguintes são consecutivos.
Com certeza ficaria bem mais complexo e nem sei se é possível com fórmula.
Mas vamos aguardar pra ver se aparece alguma solução que contemple sequências mescladas.
Ab.
Avatar do usuário
Por Estevaoba
#60954
O mais próximo que cheguei foi com esta fórmula que contempla o primeiro grupo de células não vazias, no caso 14 sendo que cinco 33 e nove 41:
Código: Selecionar todos
=CONT.SE(G9:ÍNDICE(G9:CC9;CORRESP(1;1+G9:CC9;0));D12)
A parte ÍNDICE & CORRESP limita a CONT.SE num intervalo até a primeira célula vazia, representada na fórmula como 1, por causa da matriz alterada 1+G9:CC9 que resulta em 34\42\34... e 1 (resultado de vazio mais 1).
Favor conferir no anexo se serve para te trazer um Norte.
A desvantagem dessa fórmula é que ela não funciona se a primeira célula for vazia.

Ab.
Você não está autorizado a ver ou baixar esse anexo.
Angra agradeceu por isso
Avatar do usuário
Por Kledison
#60958
@Angra !

O botão para marcar resolvido ainda não está disponível.


Att

Olá pessoal, espero que estejam bem. Tenho[…]

Boa noite. Sou novo no VBA, veja se resolve o seu […]

Top, asism ficou bem melhor, Muito Obrigado

Erro em tempo de Execução...

Bom dia amigos, neste código abaixo esta da[…]

Boa tarde. Segue uma opção. At&ea[…]

Leitura de planilha fechada

Consegui explicar :) :shock: :?: :?: N&at[…]

Bom-dia! Numa pasta do servidor [ D:\Server\BemVi[…]

Enviando email outlook

Boa tarde! Estou usando o codigo abaixo e esta fun[…]