Dúvidas sobre cálculos, funções simples e aninhadas, fórmulas matriciais, etc.
  • Avatar do usuário
Por webmanpt
#65967
Olá,
Tenho na coluna A várias datas e algumas repetem o mesmo dia.
Queria saber se existe alguma forma de contar o número único de dias. Por exemplo:

22/07/2021
22/07/2021
23/07/2021
23/07/2021
23/07/2021
23/07/2021
24/07/2021

Isto devia dar 3 Dias
Por webmanpt
#65970
Foxtri escreveu:Boa tarde
Segue uma opção
Até
Foxtri
Obrigado, funciona muito bem!
Reparei agora é que tenho um problema. O que eu quero é a contagem desde o dia mais antigo dia (por exemplo A50) até ao dia mais recente (por exemplo A2).
Peço desculpa, mas só agora me deparei com o problema que deste modo não está a contar quando não existe 1 ou mais dias indicados, e eu preciso de saber os dias passados na mesma.
Por webmanpt
#66009
Foxtri escreveu: 26 Jul 2021 às 07:33 Bom dia.
Talvez desta forma ??
=SOMA(SE(FREQÜÊNCIA(DIA(A1:A1000);DIA(A1:A1000))>0;1))-1
Até
Foxtri
Tentei essa, mas parece não estar a funcionar
Imagem

Meu excel está em Inglês. Usei:
Código: Selecionar todos
=SUM(IF(FREQUENCY(DAY(A4:A1000);DAY(A4:A1000))>0;1))-1
Avatar do usuário
Por Foxtri
#66011
Bom dia.
Verifiquei aqui na planilha conforme a imagem enviada, e não apresenta erro.
O erro que aparece de estar relacionado com a forma que vc esta tentando inserir a fórmula.
Até
Foxtri
webmanpt agradeceu por isso
Por webmanpt
#66013
Foxtri escreveu: 27 Jul 2021 às 09:35 Bom dia.
Verifiquei aqui na planilha conforme a imagem enviada, e não apresenta erro.
O erro que aparece de estar relacionado com a forma que vc esta tentando inserir a fórmula.
Até
Foxtri
Vou tentar perceber onde está o erro. Obrigado!
Por osvaldomp
#66018
webmanpt escreveu: 27 Jul 2021 às 09:11 Meu excel está em Inglês.
Já experimentou a vírgula no lugar do ponto e vírgula ?
webmanpt agradeceu por isso

Boa tarde Pessoal, Preciso criar uma coluna na mi[…]

DESCOBRIR TAJA DE JUROS AO DIA

Boa tarde a todos, Estou com uma relaç&ati[…]

Configurar impressão

Tenho um botão na minha planilha Excel de i[…]

Criar gráfico de Pareto

Muitoo obrigado, deu certinho!! Vou dar uma estuda[…]

Planilha Lenta (Fórmula Matricial)

Caríssimo osvaldomp - 22 Set 2021 à[…]

Boa Tarde! Prezado Basole - 21 Set 2021 às[…]

Boa tarde, não estou conseguindo fazer a f&[…]

Dúvida de Pesquisa

Boa tarde. Segue uma opção Sub Proc[…]